Hydraulic pump question

Farmall Cub Forum -- Questions and answers to all of your Cub related issues.

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.

Hydraulic pump question

Postby Maritimer » Thu Apr 15, 2004 1:41 pm

Started my cub today to try and hook up the cultivators. My touch control thing is stuck, the handle moves fine. Won't move a millimmeter, its locked up solid. Fluid is good and it was working last summer. I replaced the motor this winter and put the pump on the motor. Now she seems to be stuck. I tried to purge the air out of it, but it won't move to purge the air. I took the pump off and hooked it up to my drill to see if it was pumping. I poured some fluid into both inlets and outlets and started the drill. One sucked and one pushed the fluid out. But not really hard. I would think there should be more pressure than this. It just more or less bubled over. from what I tried to explain, does anyone have some input on my delema?

Oil is not leaking out anywhere. Also, the gear on the pump is good, the Key is in place and is not spinning on the shaft.
My dad once told me if it wasn't for bad luck......I wouldn't have any luck at all......
Maritimer
10+ Years
10+ Years
 
Posts: 145
Joined: Mon Feb 02, 2004 7:05 pm
Location: Brookfield Nova Scotia

Postby Jim Becker » Thu Apr 15, 2004 1:59 pm

The head of the main Touch-Control block has a pipe plug screwed into it. You may have to remove the instrument panel to get at it, but remove this plug. Behind it is a fitting with a small orifice in it. The orifice is probably plugged with some dirt that got into the system.

Look on Rudi's server for the Touch-Control Service Guide. You should find an illustration of the parts I am refering to.
User avatar
Jim Becker
Team Cub
Team Cub
 
Posts: 11972
Joined: Sun Feb 02, 2003 3:14 pm
Location: MN
Zip Code: 55319
Circle of Safety Award
Circle of Safety: Y


Return to Farmall Cub

Who is online

Users browsing this forum: Larry in WNY and 6 guests