Reinstalling Touch Control

Sat Jun 12, 2004 6:02 am

A question for the Touch Control Experienced:

I removed the touch control unit of my 51 to better degrease prior to priming and painting. I wasn't planning to do any work on it - just bolt it back on after painting. Now it's getting to be that time.

One of the two piston rods - the "control valve" the manual calls it - has worked its way outward. There is an exposed O-ring on the shaft several inches out. The rod is still connected - presumably the leather boot is holding it from coming out further - but I can't work it back in no matter how much I push on it.

How can I get it back in? Should I replace the O-ring? I hadn't noticed any leaks prior to removal. But it has been sitting exposed for several months. I really didn't want to disassemble the Touch Control but this sure would be the time to do so while it's off, if I need to.

Thanks in advance

Paul

Sat Jun 12, 2004 8:07 pm

Paul,Try to grease O-ring up with vasoline or some Hy- tran lube(on your finger) and work it back in if you can.If not take, the whole thing down.Thats what I would do.Not much to it.In fact mine was a easy.Match all the o-rings up .keep the the area clean when you work on it.Case /IH has all the parts if need be.Boots, etc.inspect all the parts and re-assemble.Use the Manual.My filter strainer was old and broken apart. Lots of $ for that.My cub is a 1960.If your going to use it alot ,think about it Just my 2 cents

Sat Jun 12, 2004 8:10 pm

Sorry for the double posts, to many baseball games today.My son's