Woo-Hoo! It works!

Farmall Cub Forum -- Questions and answers to all of your Cub related issues.

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Dennis (51)
10+ Years
10+ Years
Posts: 40
Joined: Mon Feb 03, 2003 6:42 pm
Location: Northern Virginia

Woo-Hoo! It works!

Postby Dennis (51) » Fri Nov 12, 2004 8:29 am

Well sort of....

Just rebuilt the carb on my 51 with an IH kit from C&G. Started up on the first pull of the starter rod. Runs much better than it did before the rebuild but I still don't have full power and it wants to stall when I give it throttle. Any thoughts?

I replaced the plugs, wires & Dist. cap before the carb rebuild but didn't do any thing to the points/condensor etc. Gonna check the electrics but its raining today.


TIA for any advice

Dennis (51)

User avatar
Bigdog
Cub Pro
Cub Pro
501 Club
501 Club
Posts: 24066
Joined: Sun Feb 02, 2003 12:50 pm
Zip Code: 43113
Circle of Safety: Y
Location: OH, Circleville

Postby Bigdog » Fri Nov 12, 2004 8:46 am

Dennis - yes you need to check the points & condensor- re-set or replace them if needed. Also, you may want to check your timing. Did you check your float level with a clear tube? One other thing to try is to disconnect the air inlet tube from the air cleaner to the carb to see if it is getting enough air. How long has it been since you serviced the air cleaner?
Bigdog
If you can't fix it with a hammer, you've got an electrical problem.

My wife says I don't listen to her. - - - - - - - - Or something like that!

Image

http://www.cubtug.com

User avatar
Dan England
Cub Pro
Cub Pro
501 Club
501 Club
Posts: 3094
Joined: Sun Feb 02, 2003 8:37 pm
Zip Code: 71770
Skype Name: danengland1
Location: AR, Waldo

Postby Dan England » Fri Nov 12, 2004 8:57 am

You might want to check the governor-carb linkage to check for excessive free play at the governor and also see if the linkage to the carb might be rubbing against motor parts so that it doesn't move freely. Dan

Dennis (51)
10+ Years
10+ Years
Posts: 40
Joined: Mon Feb 03, 2003 6:42 pm
Location: Northern Virginia

Postby Dennis (51) » Fri Nov 12, 2004 11:17 am

Air cleaner was serviced during the plugs/wires work. Also checked to see that the air cleaner to crancase tube was clear. Governor linkage seems OK. Gotta finish the electrical stuff, I guess. Thanks for your help guys.

Dennis (51)


Return to “Farmall Cub”

Who is online

Users browsing this forum: Kirk-NJ and 2 guests