charging... only at full throttle?

Tue Jan 08, 2013 12:03 pm

My cub seems to be charging only at full throttle. At anything less, it will just run the battery dead. Is there a guide to troubleshooting this or is my generator probably just shot? It is a 73 cub with a 12v system.

Re: charging... only at full throttle?

Tue Jan 08, 2013 6:04 pm

Belt tight and ingood shape?
Check for loose/corroded connections.
Is it an alternator or generator?

Re: charging... only at full throttle?

Tue Jan 08, 2013 7:19 pm

Here is a good document to get the basics. Older systems used what is called a cutout relay to control the charging system. You have a voltage regulator so follow the suggestions for a VR, not the cutout. http://www.farmallcub.com/fcman/files/Service%20Manuals/Delco%20Remy/Charging%20System%20Checks.pdf

Re: charging... only at full throttle?

Tue Jan 08, 2013 10:16 pm

Sounds like you have slipping belts.
1. When you turn the fan with the tractor in neutral, does the crankshaft turn?
2. Hold the cooling fan stationary, hook two fingers on the generator fan and pull. If you can't slip the generator belt, it's tight enough. If it's a double belt, 3 fingers.

Just because the belt looks good does not mean it's doing its job. For about $15 both can be renewed. Then oil the fan hub....

If belts are tight, you could have the sticking regulator like I seem to have. Rap it with a wrench has worked. Turning lights on sometimes brings it back to life. Sometimes it goes on a 30 minute vacation, sometimes shorter, but it charges enough to keep the battery up.

Re: charging... only at full throttle?

Wed Jan 09, 2013 10:53 am

Wouldn't slipping belts produce smoke and smell after a little while, though?

Check this out for troubleshooting generators:
http://www.ytmag.com/cgi-bin/viewit.cgi?bd=jd&th=304795

Re: charging... only at full throttle?

Wed Jan 09, 2013 2:24 pm

Matt Kirsch wrote:Wouldn't slipping belts produce smoke and smell after a little while, though?


Almost never. If its slipping, horsepower is lost between the drive and driven pulley, its still turning but not at full efficiency. The belt will glaze up creating a protective coating preventing the belt material from melting.

If the driven pulley is completely locked up and the drive pulley has enough power to remain in motion, at that point you will observe smoke and usually some noise to go along with it.

Re: charging... only at full throttle?

Wed Jan 09, 2013 5:39 pm

Mine was doing something a little different, but along the same lines - it would charge at low speeds, but the at higher speeds, it would stop charging.
I checked the belts and lo and behold, they were a little loose - fan especially. They were too shot to tighten so then new belts.
New snug belts charged perfectly, but loaded up the dry fan hub and it locked up in just a little bit of running.

Your belts may be transmitting just enough torque at the higher speed to excite the field.
Slipping belts don't normally make enough heat to actually smoke the belt, but rather they just get a little hot.

The 2 finger/3 finger trick I learned in service school at Cat. Works like a champ.

Re: charging... only at full throttle?

Wed Jan 09, 2013 6:52 pm

I am betting on the voltage reg!

Re: charging... only at full throttle?

Thu Jan 10, 2013 10:06 am

Take the cover off the regulator and while it's running, push down on the contactor tabs one at a time. They should spark when you break contact. If they are closed and not charging, you have a generator problem. Sometimes cycling the tabs convinces everything to work again like it's supposed to. That's one ME solution to an electrical problem....

Re: charging... only at full throttle?

Mon Jan 14, 2013 4:39 pm

Looks like we have a winner with "SLIPPING BELT".

I did get a little smell out of it..... after it threw the belt off the generator!

Anyone know the correct size belts for generator and fan off the top of their head?

Re: charging... only at full throttle?

Mon Jan 14, 2013 4:53 pm

22 inches