Switch to full style
Farmall Cub Forum -- Questions and answers to all of your Cub related issues.

Forum rules

Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Post a reply

Hydraulics do not work?

Fri Jan 25, 2013 10:18 am

When I got my arts cub running the only thing I found that I couldn't figure out were the hydraulics. The lever moves freely and easy and I have filled the reservoir up till oil runs out and ran the tractor and added more fluid untill no more would go in and I still get nothing to work, I don't even hear a sound from the unit. It is not going into the motor either as the oil level has not changed since I changed the oil a while back.

I was just wondering if I need a pump rebuild or maybe I have a blockage inside the unit?? I have never worked on Cub hydraulics so I am courious as what I need to try before I start to tear into it.

Thanks

Re: Hydraulics do not work?

Fri Jan 25, 2013 10:33 am

My first suggestion would be to remove the pump and see if the gear is still on the shaft. This will require draining the hydraulic oil first and you'll probably want to replace gaskets. If the gear is there, and it turns freely, it's probably time for a rebuild of the pump and block.

Bob

Re: Hydraulics do not work?

Fri Jan 25, 2013 10:46 am

Before you remove the pump you might try removing the top plug (requires an allen wrench, and will be very tight) on the block where the lines attach to the main unit. If oil is pushed out that hole with it running the gear is probably there. If oil just trickles out, it may be that the gear has come off, as Bob mentioned. sometimes if they have set for a while they get air locked, and removing that plug and letting the air out while it is running may clear it.

Re: Hydraulics do not work?

Fri Jan 25, 2013 12:34 pm

You say the lever moves free and easy.... Look and see if it's actually attached to anything. It should move a plunger in and out on the lower right front corner of the hydraulic block.

It took 7-8 full cycles of the hydraulics for mine to come back to life when I rebuilt my pump last fall.
Post a reply