Touch Control

Fri Mar 28, 2014 9:12 pm

Was plowing snow and blade was working perfectly. I let the blade down, and when I went to raise it, nothing. No noise, no drag on engine. Took pump off and appeared OK. Put pump back on, started engine, again nothing. Loosened line from pump, and oil just seeped out. not under pressure. Ideas?

Re: Touch Control

Mon Mar 31, 2014 10:29 am

Hopefully not being over obvious, but did you check the hydraulic oil level? If it is low, be careful not to overfill. You'll need to bleed the air out of the system by cycling the controls back and forth.

Re: Touch Control

Mon Mar 31, 2014 10:42 am

Also, check your engine oil. If it is over filled all of a sudden, your pump has begun to leak into the engine oil. There is a rebuild kit for the pumps available at TM Tractor or at your local IH dealer that will help to stop any leaks there. Most likely, the shaft o-ring seal (or if an older cub, just a seal) has worn and is leaking. Also check the shaft of the TC pump for grooves where the o-ring rides as this can cause a leak as well.

Mike

Re: Touch Control

Wed Apr 02, 2014 6:14 pm

Oil is fine. Changed the hydraulic fluid and cycled the TC, no difference in the engine oil. Will remove the pump again and check the o-ring / or seal. Not sure which it has, however I believe it has o ring. Could it be something in the box that would go that quick?

Re: Touch Control

Wed Apr 02, 2014 6:46 pm

I know it may sound simple, but check the linkages to be sure they are still connected. That includes linkage on control valve(small rod by the main cylinder). Can be easily overlooked

Re: Touch Control

Fri Apr 04, 2014 7:25 pm

hey sorry to say but mine did the same thing i pulled it down and found 2 o-rings blown apart ...

Re: Touch Control

Sun Apr 06, 2014 7:35 pm

ordered kit for pump. Will see if that takes care of problem. Everything seemed OK, but will try kit. Don't want to go into the box if I don't have to.