stuck touch control...help!

Fri Nov 12, 2010 4:29 pm

well i have gotten my pump rebuilt and back on the tractor(1953 farmall super a) today. filled the touchcontrol unit with hytran and left the fill plug out and ran it for a bit to get the air out. the first time i fired it up i did not have a good seal where the lines mount to the touch control, but the left arm did move even thou it was leaking fluid out of the flange. so i took the lines off and cleaned up the face again and remounted them. put more fluid in and fired it up with no leaks but the arms did not move at all this time :censored: i shot them down with PB blaster(a whole can) and that did nothing to help. i pried and tapped the little arm that the rod connects to in an effort to free it up with no change :?

i did notice that the first time i fired it up white fluid was coming out of the fill hole( water/hytran mix) so i drained the system 2 times to get rid of it......still white.....so could the pistons be frozen with rust?

i really dont want to have to tear it down, but in the end if i have to i will

Re: stuck touch control...help!

Fri Nov 12, 2010 5:06 pm

It could be just air locked. Keep cycling the control and see if it works out. The fluid will be a little white if there is an abundance of air.

Re: stuck touch control...help!

Sat Nov 13, 2010 3:30 pm

In addition to Cecils comment , it does take a while sometimes for the system to "start up again". I have had non-runners that became runners with nonfunctioning hydraulics only to begin working after a good running of maybe 30 minutes or so. :D Not that yours will do this, just more input.. good luck.