Switch to full style
Farmall Super A, AV, 1939 - 1954

Forum rules

Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Post a reply

generator on A

Fri May 27, 2011 7:37 am

I have a farmall A that I have put on a different generator on. (old ac delco off from a convertiable 50's car) it has hydraulic pump built on it.

Anyway I have it all hooked up and when I first start the tractor I have to jump a wire from the bat terminal on the regulator yes its a regulator to the A and F terminal on the generator if I do not do this it wont charge. I know your not suppose to do this but I did it one day and it works every time I jump it. Now if I use the tractor every day it will start up and start charging but if I let it go over a 2-3 day period it will have to be jumped to start charging again.
what is going on and how can I fix it? I think I have a 12volt regulator on it but with the generator it puts out about 15-18 amps and puts out about 6.8-7.2 volts at the battery.
does anyone know why it looses its contacts or what ever when it sits?
Thanks
Chad

Re: generator on A

Fri May 27, 2011 8:36 am

That is a kind of strange one. I don't have an answer but I would start by going back over all connections, including grounds. Bad grounds can produce all sorts of strange behavior. Are you using a regulator that belongs with that generator (like off the same car)? Most car companies changed from 6 to 12 volts during the '50s. Do you know the car make and exact year? Is there a data tag still on the generator? What number is stamped into it and what color is the background? Delco black tags are 6 volt and red tags 12 volt. What voltage battery are you using?

Re: generator on A

Fri May 27, 2011 11:50 am

Jim
its a 6volt I looked it up and the tag is still there but don't know it off the top of my head. Its off a chrysler.
the generator is 6 volt. the regulator is from something newer that was 12 volt like a sears suburban 10.
Its a 6 volt battery and when it charges it puts about 6.8 to 7.2 volts at the battery when running.
when I put a 12 volt battery on it it charges that just fine about 12.8 volts or so.
I just tried it one day and was going to put a 6 volt regulator on there but when I did that it seemed fine and left it.
I have all new wires on it I even put a ground wire from the generator to ground. Every 6 volt regulator I put on there wont work unless I ground the feild. I put this one on there and it worked. I original was going to make it 12 volt but when I got home I walked out of TSC with the 6 volt and didn't realise what I did till it was all hooked up and running and was charging I have done this for 2 years now just getting tired of jumping it. I will try cleaning all the connections again and see if it holds.
It is a mag tractor so there is no draw on it. I took the lights off and there on my Super A. I might have even by-passed the light switch so I could let the regulator work right.
Chad
Post a reply