Super A Governor Troubleshoot

Sun Dec 11, 2011 10:29 am

On my "new" Super A, you have to go from the lowest position on the trottle lever (low idle) up to about half way before you get any increase in RPM. I don't have a hand held tach to check at the PTO shaft, but I don't think it's at rated RPM when the lever is all the way forward (high idle). Also if you quickly advance the throttle you get some surging.

I think I can deal with the surging but what causes it to take so much movement on the trottle lever to get a RPM increase? I haven't checked anything yet, I wanted to get some input from the group first.

thanks,
Al

Re: Super A Governor Troubleshoot

Sun Dec 11, 2011 11:33 am

I just went through the same thing on my Super A. The first problem was my Carb. It was missing the well vent jet. I got a rebuild kit that had one and replaced the needle and seat, adjusted the float by eye, for some reason it was way too high and flooding by spec. Probably something I was doing wrong. Mine had a lot of surging when at high throttle and using the hydraulics or starting out in gear.

So now I'm pretty sure I have the carb ok and adjustments are at start up mode and fine tune when running. I removed the governor and cleaned everything, put in new spring, it was slightly shorter than the original from being stretched for so many years. I adjusted the carb linkage to Gov linkage as per book. I fired it up and it started right away, it never did that before so I'm feeling pretty good. I gave it full throttle and it had a terrible surging so I started with the carb air-fuel screw and backed it out until it ran pretty smooth. I had the gov adjusted all the way out so it really had no gov at that point, so it surged bad when putting any load on engine.

I loosened the gov adjustment and started turning clockwise until all surge was gone. I don't have a tach either, so I adjusted the High end by ear on the gov for now. This thing has NEVER run this good. I also had the problem of not getting throttle responce until about half the way up the pegs, now it increases every notch.

I think most of my problem was the carb, but I'm sure cleaning the gov and installing a new spring didn't hurt. Also make sure there is NO binding in any of the linkage. I flipped my linking around on the carb end and that eliminated some binding.

You might have other problems, but that cured mine to an unbelievable difference in every aspect of drivability.


Good luck, Tom

Re: Super A Governor Troubleshoot

Mon Dec 12, 2011 7:08 pm

twotone wrote:I just went through the same thing on my Super A. The first problem was my Carb. It was missing the well vent jet. I got a rebuild kit that had one and replaced the needle and seat, adjusted the float by eye, for some reason it was way too high and flooding by spec. Probably something I was doing wrong. Mine had a lot of surging when at high throttle and using the hydraulics or starting out in gear.

So now I'm pretty sure I have the carb ok and adjustments are at start up mode and fine tune when running. I removed the governor and cleaned everything, put in new spring, it was slightly shorter than the original from being stretched for so many years. I adjusted the carb linkage to Gov linkage as per book. I fired it up and it started right away, it never did that before so I'm feeling pretty good. I gave it full throttle and it had a terrible surging so I started with the carb air-fuel screw and backed it out until it ran pretty smooth. I had the gov adjusted all the way out so it really had no gov at that point, so it surged bad when putting any load on engine.

I loosened the gov adjustment and started turning clockwise until all surge was gone. I don't have a tach either, so I adjusted the High end by ear on the gov for now. This thing has NEVER run this good. I also had the problem of not getting throttle responce until about half the way up the pegs, now it increases every notch.

I think most of my problem was the carb, but I'm sure cleaning the gov and installing a new spring didn't hurt. Also make sure there is NO binding in any of the linkage. I flipped my linking around on the carb end and that eliminated some binding.

You might have other problems, but that cured mine to an unbelievable difference in every aspect of drivability.


Good luck, Tom


Thanks for the advice. I think I will clean it up and check the spring and linkages first.

Al

Re: Super A Governor Troubleshoot

Thu Dec 15, 2011 9:25 pm

How much "slop" is acceptable for the lever on the governor housing where the throttle rod (from the instrument panel) connects? It will wiggle around in the housing. The governor arm which connects to the carb doesn't seem to have any lost motion in it. I expect the governor spring is pretty stretched too.

Al

Re: Super A Governor Troubleshoot

Thu Dec 15, 2011 9:39 pm

Mine doesn't have any slop at all, but the rod has upper movement when pushing the throttle foreward. At the rear right side of the head is a tapped hole with nothing in it, so I made a clip that lets the rod slide through it, but eliminates the rod arching upward. I would take the governor off and see what's going on in there.


Tom