Switch to full style
Farmall Super A, AV, 1939 - 1954

Forum rules

Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Post a reply

SA touch control rebuild

Wed Mar 21, 2012 9:16 am

I recently rebuilt my SA touch control and ordered the kit from IH. It was working but leaking around the pistons quite a bit. The rebuild went good, put it back together and installed it on the tractor and made the adjustments per IH manual. It works fine except with this problem, when I turn off the engine, the hydraulics bleeds down pretty fast, fast enough to see it lowering. Which o ring causes this?
My gut feeling is the o rings on the control rods. In the kit, all the o rings were black like the original ones except the 4 for the control rods which were blue (two on each rod). I'm suspicious of these because when I rebuilt it, I dropped each o ring in hydraulic fluid before installing them and the blue ones would leave a blue residue on my fingers when I picked them up, the black ones didn't leave any black residue. Suspicious, but trusting IH, I used the o rings anyway but now I suspect them of being the problem.
Gerry
Last edited by Gerry Powell on Wed Mar 21, 2012 5:03 pm, edited 1 time in total.

Re: SA touch control rebuild

Wed Mar 21, 2012 1:06 pm

The o-rings are a seal to prevent fluid leaking out, the metal to metal fit of the rod is what regulates the oil flow as I remember. Go to the Blue Ribbon manuals on teh manual server and read the trouble shooting section, I think it will help you.

Re: SA touch control rebuild

Wed Mar 21, 2012 9:07 pm

Gerry,
I just rebuilt the TC on my 130, which is the same as the SA.
I read the instructions that came with the kit. The blue ones were OK for the control rods. You should have 4 of them left over.
What about the check valves? Are you certain they all went in the proper way?
Does the system leak down on both front and rear?

My unit will not be going on the tractor for quite some time as I am still prepping everything to paint.

Ed

Re: SA touch control rebuild

Thu Mar 22, 2012 9:09 am

Ed,
I don't know about the front, I just use the back. I'll try it later.
I put everything back according to the parts diagram, the check valves went in correct way. It works ok, just bleeds down fast when the pump is turned off, something is wrong, I just don't know which o ring would cause this. It's basically the same design as my Cub and it doesn't bleed down.
Post a reply