Switch to full style
Farmall Super A, AV, 1939 - 1954

Forum rules

Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Post a reply

Super A Governor Bumper Spring

Thu Mar 22, 2012 9:44 am

I had the governor on my Super A rebuilt and I have installed it, throttle response is 100% better and I have speed adjustment across the entire range of the quadrant. However, I can't quite get it set up like I want. When I installed it, it surged some so I removed the "acorn nut" at the base of the governor housing and turned the set screw in, per the instructions in the service manual. I finally turned it in so far that I had to remove the jam nut in order to get the acorn nut back on. I noticed that this seemed to affect my idle speed (idled a little faster) So I adjusted it again yesterday--turned the screw out just far enough to get the jam nut and the acorn nut back on. It runs ok but I can still detect a tiny bit of surging when you rapidly accelerate or deaccelerate. So my question is, does that spring get worn enough to prevent proper adjustment?

Again this is not the main governor spring, this is the bumper spring...

thanks
Al

Re: Super A Governor Bumper Spring

Fri Mar 23, 2012 9:02 am

When I rebuilt my TC on my Super A, after I adjusted everything in the carb side of the tractor I went and adjusted the governor. It didn't take much and I had it running beautiful. I do have a very small surge when I ram it from idle to wide open but I think that is acceptable. I believe even the book says 1 or 2 slight surges are ok.


Tom

Re: Super A Governor Bumper Spring

Fri Mar 23, 2012 10:13 am

I would suggest backing the spring off to its original setting and using it a few hours before adjusting. The pivots may be a little stiff, and the new seal tight on the shaft causing it to surge when finding right rpm. let it run in a while then try again.

Re: Super A Governor Bumper Spring

Fri Mar 23, 2012 12:06 pm

John *.?-!.* cub owner wrote:I would suggest backing the spring off to its original setting and using it a few hours before adjusting. The pivots may be a little stiff, and the new seal tight on the shaft causing it to surge when finding right rpm. let it run in a while then try again.



John,

I had already run it a while before I adjusted it.

Al
Post a reply