782 Coil

Sun Aug 03, 2014 2:00 pm

I mowed with my "new" 782 yesterday. She ran good for about 30 minutes then all of a sudden she started to miss and died. After about 10 minutes I got it to run but it died right out again. I left it cool all the way down, and it started right up and ran fine. Previous experience says it "must" be the coil. Am I missing anything? I will check the points/condenser too.

Can you get an electronic ignition kit for these old Kohlers? I am not a huge electronic fanatic, (all my old Farmalls still have points) but being the 782 will see seasonal use so I wonder if electronic ignition might head off problems down the road.

thanks,
Al

Re: 782 Coil

Sun Aug 03, 2014 4:05 pm

try kirk engines inc, google it they have some nice electronic setups

Re: 782 Coil

Wed Aug 06, 2014 7:42 pm

Al,
I have to change the points on my 1650 every couple of years. They are about 8 bucks at carquest. Never had a coil go on mine (sure, it will happen tomorrow since i said that) but it sure sounds like that might be the problem. Mine will just quit like its outta gas...it loses spark that quick when the points go, and while I am a cheapskate, and own a points file, for 8 bucks it aint worth messin with. I slap a new set on and off I go.

Re: 782 Coil

Fri Aug 15, 2014 5:22 pm

I got my new coil and installed it. I noticed the engine started easier so I thought I had it made. It ran about twice as long before and then the same symptoms--a slight miss got worse and worse until it died, with a couple big BANGS before it completely died. I'm going to try a set of points and condenser and see what happens then.

Any other ideas appreciated! I have heard horror stories about valve seats coming loose when the engine warms up, I hope it's nothing like that!

Al