Switch to full style
IH CUB LoBoy Series - 154, 184, 185 Forum -- Questions and answers to all of your LoBoy related issues.

Forum rules

Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Post a reply

my 154 is driving crazy

Mon Feb 18, 2013 11:03 pm

when i got my 154 it would start but run rough. governor arm was froze up. got all that to working new points,plugs,condenser, cap,rotor,set valves timed it acording to the book started it no difference . pulled carb. off another cub put it on the 154 no difference. new wires to. don't know what else to do. all help is welcome. thanks tom. :headbang

Re: my 154 is driving crazy

Mon Feb 18, 2013 11:20 pm

First thing is a compression test, dry then wet.

2 timing marks on crankshaft front pulley. Check timing with timing light.

With timing light, check for spark on each plug wire. Check cylinder #1 and #4 spark - they should match the advance timing mark on front pulley at full engine rpms.

If you have a vacuum gauge. Use it. It will tell you a lot about the engine condition and faults.

Edit: Timing light, check for sticking - stuck distributor mechanical advance.
Last edited by Eugene on Tue Feb 19, 2013 6:23 am, edited 1 time in total.

Re: my 154 is driving crazy

Tue Feb 19, 2013 5:54 am

tom, before you pull your hair out and/or tear into it, put a can of seafoam in it and run it for 30 minutes or so. Sure helps some of them. 1/2 can in the oil and 1/2 can in the fuel.

Re: my 154 is driving crazy

Wed Feb 20, 2013 8:33 pm

Something else to check, while you're running it on Seafoam. Look at the throttle linkage from the governor while the engine is running. I've seen WAY more than a few Cubs and Lo-boys that the throttle linkage was bound up on the block, or rubbing something else nearby, and preventing the governor from actually controlling the carburetor correctly. If those little arms get bent a little too much the wrong direction, they'll hang up or rub against things. The tractor will run, and all will seem to be working fine, but that little bit of rubbing is actually enough to make them surge and hunt, preventing the governor from working quick enough.

Re: my 154 is driving crazy

Thu Feb 21, 2013 8:37 pm

thanks guys. my internet service has been out for 3 days, like to have went nuts. :lol: real nasty weather here . went to harbor freight yesterday and bought a compression testing kit and a few other things. going to get back on the 154 hard heavy this weekend. thanks for the info. tom

Re: my 154 is driving crazy

Fri Feb 22, 2013 6:19 pm

ok, this is what i have on compression
. #1 has 65 lbs dry 105lbs. wet.
#2 has 60lbs. dry 135lbs wet.
#3 has 50lbs dry 104lbs. wet.
#4 has 55lbs dry 106lbs. wet.
ok so now what does this tell me cause i don't know. all help is welcomed. thanks very much. tom

Re: my 154 is driving crazy

Fri Feb 22, 2013 6:26 pm

one more thing, let the 154 run for a little bit and the coil got hot, could not hold your hand on it. is that good or not? thanks tom

Re: my 154 is driving crazy

Fri Feb 22, 2013 6:35 pm

From those numbers, I'd say you have bad rings. You may be able to run Seafoam or Marvel Mystery Oil is the gas to clean and loosen them up to increase the dry compression readings, or you may have to tear into it.

Re: my 154 is driving crazy

Fri Feb 22, 2013 6:54 pm

ole man, the guy i got it from said it set for a couple of years so maybe its just stuck i hope. gone to try every thing before i tear it down. thanks tom

Re: my 154 is driving crazy

Fri Feb 22, 2013 6:55 pm

Tomcat I'll just pop on over there and put it on my trailer. Won't drive you crazy then! :lol:

Re: my 154 is driving crazy

Fri Feb 22, 2013 7:06 pm

come on up thomas an d we will have another cubfest and get it running. tomcat

Re: my 154 is driving crazy

Fri Feb 22, 2013 7:13 pm

I would try the Sea Foam or Marvel Mystery Oil, operate the tractor, work it hard, for a length of time to see if the rings free up.

Coil. Warm but not hot. Remove the coil. The lettering may tell if you need an external resistor. Part number can be checked for type of coil. You need a coil with an internal resistor or a coil with an external resistor.

Compression is low - but probably not the cause of the "run rough" problem. Check, then double and triple check the ignition and ignition advance.

Re: my 154 is driving crazy

Fri Feb 22, 2013 7:17 pm

thanks eugene, i will sure check, thanks for your help. tom

Re: my 154 is driving crazy

Sat Feb 23, 2013 1:31 pm

You have not stated if it has blowby or exhaust smoke when running!---if it does ---dont waste more time on the bandaid fixes.---it needs an engine rebuild!---How do I know??? got a 49---smoked when I got but ran and I used it a little,--not much power , no oil pressure after it got warm, and gov. never did work!---It became parts unit for the 56 and I never plan on fixing the motor! (too costly for me) thanks; sonny

Re: my 154 is driving crazy

Sat Feb 23, 2013 1:58 pm

what little it did run i did'nt notice any blow by. took the oil light out and put a gauge on. it had good oil pressure but could not get it to rev up. governor and all linkage is freed up.in the process of pulling the head now but got to quit for the day and go to the chili cook off at the VFD. i did notice that some of the springs on the valves did not look right 3 of them looked stretched out,but i do not know. get back on it tomorrow. thanks for the help. tomcat
Post a reply