Replacement bad new S/G on ebay

Fri Jun 27, 2014 7:13 pm

Last year I purchased a replacement New starter/generator on eBay.
NOT PURCHASED FROM HAMILTONBOBSCUBS. After all my son's work the last problem is this brand new starter starts fine but after it gets hot the starter part of it didn't turn over the engine. The battery is getting 13+ volts when it's running. The new starter is banging away when it clicks so the voltage is there. If we jump it when it's hot it will start. I guess my son's will fix this next.

I think the new S/G is from China.

Re: Replacement bad new S/G on ebay

Fri Jun 27, 2014 7:38 pm

viewtopic.php?f=31&t=84399

Re: Replacement bad new S/G on ebay

Fri Jun 27, 2014 10:04 pm

When it's cold the starter works. My son fixed the ground wire we have 13+ volts at the tranny cover. The engine toys over when it's cold. Nothing happens at the starter when it's hot only the loud solenoid click.
This new solenood really bangs in so it has plenty of voltage. My son installed a new wire harness so I'm sure all the connections are clean. I have a used starter to try next.

Re: Replacement bad new S/G on ebay

Sat Jun 28, 2014 11:44 am

My thought, rebuild or have rebuilt the original USA manufactured starter/generator. Quality of finished product will probably be much better than you can get from an unknown e-bay item.

Re: Replacement bad new S/G on ebay

Sat Jun 28, 2014 12:09 pm

I have the old one and I have new brushes and the bearings here in-house. I just got lazy since I been sick. I purchased the new s/g about a year and a half ago. Then I purchased most of the electrical stuff brand new so my problems would be over. But now it's running.