1974 Cub 154 Loboy no spark after installing 1442 electronic ignition

IH CUB Lo-Boy Series - 154, 184, 185 Forum -- Questions and answers to all of your Lo-Boy related issues.

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
SONNY
10+ Years
10+ Years
Posts: 3047
Joined: Thu Nov 09, 2006 11:26 pm
Zip Code: 61722

Re: 1974 Cub 154 Loboy no spark after installing 1442 electronic ignition

Postby SONNY » Fri Sep 14, 2018 10:35 pm

Can't beat the ole tried and true points setup! thanks; sonny
Image

User avatar
Shane Nelson
501 Club
501 Club
Posts: 2988
Joined: Wed Nov 22, 2017 6:24 am
Zip Code: 27284
Tractors Owned: .
1947 Circle Cub #1447 (Arnold)
195? Cub
1970 International 140 (Norman)
1949 John Deere A
1972 Schramm Pneumatractor
1993 Ford 4630 W/Loader
1965 John Deere 110
1961 Cub Cadet Original
Circle of Safety: Y
Location: Oak Ridge, N.C.

Re: 1974 Cub 154 Loboy no spark after installing 1442 electronic ignition

Postby Shane Nelson » Sat Sep 15, 2018 6:20 am

boomer632 wrote:After scratching my head and pulling the dist in and out numerous times.. I decided to put the old point set back in. Touched the key and it fired right up and ran like a champ. I have determined that the most likely culprit is the module itself.
With that said.. I am going to return the part and get the Pertronix 1442 and 40611 coil. For those of you following this.. that coil is 3 OHM and has epoxy internal which is necessary for horizontally mounted coils such as in the 154's

If it ain’t broke, don’t fix it :D
God is good, all the time!
Every home is a school, what are you teaching?
Circle of Safety


  • Similar Topics
    Replies
    Views
    Last post

Return to “Lo-Boy Series - 154, 184, 185”

Who is online

Users browsing this forum: No registered users and 3 guests