154 Tach issues

IH CUB Lo-Boy Series - 154, 184, 185 Forum -- Questions and answers to all of your Lo-Boy related issues.

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.
Yellowbeard
Posts: 11
Joined: Sun May 15, 2016 8:13 am
Zip Code: 61238

154 Tach issues

Postby Yellowbeard » Fri Jun 24, 2016 3:31 pm

So I'm adjusting the throttle and governor on my 154. I can't seem to get my tach to read anything. At all. Power cables clamped to battery. Pickup cable clamped to negative side of coil. No signal. Switched tachs and still no love. New cap/rotor/points/condensor/coil. No signal. I've done this the same way for 40 years. What am I missing?

Yellowbeard
Posts: 11
Joined: Sun May 15, 2016 8:13 am
Zip Code: 61238

Re: 154 Tach issues

Postby Yellowbeard » Fri Jun 24, 2016 3:37 pm

Almost forgot: New battery, new ground strap, grounded to the frame, new plug wires, new positive battery terminal.

Larry B
Cub Star
Cub Star
Posts: 158
Joined: Tue Jul 29, 2014 4:16 pm
Zip Code: 45325
Tractors Owned: IH 184
Location: Farmersville ohio

Re: 154 Tach issues

Postby Larry B » Fri Jun 24, 2016 5:34 pm

Assuming your tach is good try disconnecting the condenser and see if it works.

BigBill
10+ Years
10+ Years
Posts: 6346
Joined: Sat Jul 22, 2006 5:02 pm
Zip Code: 00000
Location: in northern usa

Re: 154 Tach issues

Postby BigBill » Mon May 14, 2018 7:11 pm

Your feed wire for your tach goes to the distributor side of the ign coil?
I'm technically misunderstood at times i guess its been this way my whole life so why should it change now.


  • Similar Topics
    Replies
    Views
    Last post

Return to “Lo-Boy Series - 154, 184, 185”

Who is online

Users browsing this forum: No registered users and 1 guest