Still Showing No Charge on Ammeter

Farmall Cub Forum -- Questions and answers to all of your Cub related issues.

Moderator: Team Cub

Forum rules
Notice: For sale and wanted posts are not allowed in this forum. Please use our free classifieds or one of our site sponsors for your tractor and parts needs.

Still Showing No Charge on Ammeter

Postby Cub-Bud » Thu Jul 08, 2004 10:18 am

Dad's cub still doesn't show a charging condtion despite all efforts. :x According to Jim Becker, I have wired the tractor correctly. A new wiring harness was used as well as a new ammeter, new voltage regulator, new battery cables, and new battery. The lights work so, I sorta think the switch is ruled out. Also, when the lights are turned on (tractor not running), the ammeter shows a discharge, ruling out the guage. The generator has been tested twice by two seperate rebuilders and tests good. We have scraped paint off the tractor from front to back....I wouldn't think we have a ground problem. What do I check next :?: :? :? :?
"Never forget where it is you come from, or you may find yourself someplace you don't want to be"

Greg Norman
User avatar
Cub-Bud
Team Cub
Team Cub
 
Posts: 3221
Joined: Sun Feb 02, 2003 6:30 pm
Location: MS, Pope
Zip Code: 38658
eBay ID: Cub-Bud
Circle of Safety Award
Circle of Safety: Y

Postby Bigdog » Thu Jul 08, 2004 10:34 am

I know you said you changed the regulator, but it wouldn't be the first one that was bad out of the box. Have you tried grounding the generator field terminal and checking to see if it is charging?
Check the last 2 diagrams in the link below. They are troubleshooting flowcharts. One is for generator / regulator, the other is generator / cutout.
Bigdog
If you can't fix it with a hammer, you've got an electrical problem.

My wife says I don't listen to her. - - - - - - - - Or something like that!

http://www.cubtug.com
User avatar
Bigdog
Team Cub
Team Cub
 
Posts: 23820
Joined: Sun Feb 02, 2003 12:50 pm
Location: OH, Stoutsville
Zip Code: 43154
Circle of Safety Award
Circle of Safety: Y

Postby Cub-Bud » Thu Jul 08, 2004 11:23 am

Just got a phone call from Dad......mysteriously, the generator is now charging. :shock: I guess after removing it a couple of times, it has grounded good enogh to show a charge :?: He also said the rebuilder did something to it yesterday...something about the brushes "glazing-over" :?: Anyway, I think I'll go by his house at lunch and check it out. We may have just put the finishing touches on ole' Bingo :!: :D
"Never forget where it is you come from, or you may find yourself someplace you don't want to be"

Greg Norman
User avatar
Cub-Bud
Team Cub
Team Cub
 
Posts: 3221
Joined: Sun Feb 02, 2003 6:30 pm
Location: MS, Pope
Zip Code: 38658
eBay ID: Cub-Bud
Circle of Safety Award
Circle of Safety: Y


Return to Farmall Cub

Who is online

Users browsing this forum: Eugene and 3 guests